Login screen appears again

Incident Report for Spacetalk

Monitoring

Please update to our latest iOS and Android app versions 10.16.10 or greater, which resolve this issue
Posted Jan 30, 2026 - 15:14 AEDT

Identified

We are aware that some users are experiencing an issue where the login screen re-appears in the app.

A fix is being investigated.

If this happens you can simply fully close (swipe up and close the app like you would fully close any other app). Then reopen it and you should be logged back in.
Posted Dec 01, 2025 - 19:10 AEDT
This incident affects: Spacetalk App (Account Management).