Older iPhone network connectivity issue

Incident Report for Spacetalk

Resolved

This issue is now resolved.
Posted Feb 19, 2026 - 09:00 AEDT

Monitoring

Last week, Apple released a software update (iOS 16.7.13) for iPhone 8, 8 Plus and X which prevented these devices from connecting to the Telstra mobile network. A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2026 - 21:49 AEDT
This incident affected: Spacetalk Mobile Services (Australia) (Voice and Data Services).