Send and receipt of MMS messages

Incident Report for Spacetalk

Update

We are aware of an issues sending and receiving MMS messsages on Adventurer 2 watches on the Spacetalk Mobile Australia network.

Customers can workaround this currently by following the below steps:

On the watch
1. Go to settings >> Access point names >> enter password (Last 4 digits of IMEI)
2. Select "Telstra Wap" entry >> go to item "APN Type" and remove ",mms" >> touch the 3 dots in top right >> Select "Save"
3. Select "Telstra MMS" entry >> go to item "APN Type" and remove ",default" >> touch the 3 dots in top right >> Select "Save"
Posted Jan 02, 2026 - 19:13 AEDT

Identified

We are investigating an issue sending and receiving MMS messsages on Adventurer 2 watches on the Spacetalk Mobile Australia network.
Posted Dec 30, 2025 - 19:12 AEDT
This incident affects: Spacetalk Watches (Adventurer 1 and Adventurer 2).