Telstra Wholesale Network Outage Impacting Spacetalk Services

Incident Report for Spacetalk

Resolved

The network issues affecting some Spacetalk customers, caused by our network partner, Telstra Wholesale, have now been resolved
Posted Jul 10, 2026 - 09:56 AEST

Investigating

Our network partner Telstra Wholesale is experiencing a major outage impacting Spacetalk calls (including 000), texts, data, and location tracking for Watch users outside Wi‑Fi. There is currently no estimated time for restoration; Telstra Wholesale is working urgently to resolve the issue.

- Mobile calls, including emergency calls, may fail or be unreliable.
- SMS and mobile data may be degraded or unavailable.
- Watch location tracking outside Wi‑Fi may not work.

https://support.spacetalk.co/en/articles/15865235-telstra-wholesale-network-outage
Posted Jul 08, 2026 - 09:06 AEST
This incident affected: Spacetalk Mobile Services (Australia) (Voice and Data Services).