Mobile Recharge Delays

Incident Report for Spacetalk

Resolved

This issue is now resolved.
Posted Apr 02, 2026 - 12:07 AEDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 16:59 AEDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 16:58 AEDT

Monitoring

Following some issues with third party systems, some monthly Handset and Wearable mobile plans did not automatically recharge. We rectified this issue and impacted customers were notified of the successful recharge You do not need to take any action. You can check your Spacetalk App for payment history details.
Posted Jan 29, 2026 - 14:56 AEDT
This incident affected: Spacetalk Mobile Services (Australia) (Mobile Service Payments).