Third party outage affecting Australian SIM activiations

Incident Report for Spacetalk

Update

Some customers who were affected by this issue may see their plan in a Pending state. If you are affected by this, please contact us at https://support.spacetalk.co
Posted Jan 29, 2026 - 15:03 AEDT

Monitoring

SIM Activiation should now be back to normal. if you activated on 24-26 Dec & the status of your plan is still pending, try again with same SIM.
Please also contact us with email address that was charged. We will refund any duplicate charges within a week (likely in 1-2 days)
Posted Dec 25, 2025 - 23:30 AEDT

Identified

Owing to a Telstra outage we are experiencing elevated issues related to Mobile SIM activations for customers. Please try again later
Posted Dec 25, 2025 - 19:00 AEDT
This incident affects: Spacetalk Mobile Services (Australia) (SIM Activation & Management).