Duplicate charges on renewal of mobile plans

Incident Report for Spacetalk

Resolved

This issue is now resolved.
Posted Apr 02, 2026 - 12:07 AEDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 17:00 AEDT

Monitoring

This has now been resolved and impacted customers have been refunded. If you were impacted you will have been notified of the refund. Please contact us at https://support.spacetalk.co/ if you feel that you were entitled to a refund and did not receive it.

We are aware that some customers may have experienced a duplicate charge when their plan renewed.
Posted Jan 02, 2026 - 19:04 AEDT
This incident affected: Spacetalk Mobile Services (Australia) (Mobile Service Payments).