Duplicate activations and charges on purchasing new services

Incident Report for Spacetalk

Resolved

This issue is now resolved.
Posted Apr 02, 2026 - 12:07 AEDT

Update

We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 17:02 AEDT

Monitoring

Update: We have resolved this issue and impacted customers have received refunds. Please contact us at https://support.spacetalk.co/ if you feel that you were entitled to a refund and did not receive it.

We are aware that some customers are experiencing issues where the plan may not show up immediately after purchase, and are accidently attempting to purchase a plan again.
Posted Jan 02, 2026 - 19:09 AEDT

Investigating

We are aware that some customers are expeiriencing issues where the plan may not show up immediatly after purchase, and are accidently attempting to purchase a plan again.
Posted Dec 14, 2025 - 19:09 AEDT
This incident affected: Spacetalk Mobile Services (Australia) (SIM Activation & Management).