With recent network changes in New Zealand, some families may have noticed issues with calling on their kid’s Loop.
We’ve released a simple update to help restore normal calling for customers on the 2degrees network so your kid can stay safely connected with their trusted contacts.
What to do: - To update your kid’s Loop: Place the watch on charge overnight, or - On the Loop home screen: swipe down → tap the Settings icon (COG) → tap Software update → update to version 1.1.29
Why this matters: This update ensures your kid’s Loop works smoothly with newer network technology, as providers move on from 3G.
If you’re still experiencing any issues after updating, our Spacetalk Customer Support team is here to help.
Posted Apr 07, 2026 - 17:44 AEST
Update
We’ve released a new Adventurer watch update to resolve the recent calling issue experienced by some customers on the 2Degrees network in New Zealand.
For those who are based in New Zealand with an Adventurer on the 2Degrees network, please update your watch to the latest firmware (Version 20260312) and restart the device to apply the fix.
You can do this by leaving your watch on charge overnight, or swiping down on your Adventurer > tap the 'Settings' icon > tap 'Software update'.
If you continue to experience any issues, our support team is here to help.
Posted Mar 16, 2026 - 18:33 AEDT
Update
We’ve released a new Adventurer 2 watch update to resolve the recent calling issue experienced by some customers on the 2Degrees network in New Zealand.
For those who are based in New Zealand with an Adventurer 2 on the 2Degrees network, please update your watch to the latest firmware (Version 20260306) and restart the device to apply the fix.
You can do this by leaving your watch on charge overnight, or swiping down on your Adventurer 2 > tap the 'Settings' icon > tap 'Software update'.
If you continue to experience any issues, our support team is here to help.
Posted Mar 12, 2026 - 18:51 AEDT
Identified
We have identified an issue affecting voice call functionality for some watch devices on the 2Degrees network.
The devices are not correctly registering for VoLTE calls on 4G, causing them to attempt calls over 3G, which is no longer supported by 2Degrees.
We are working with network partners to confirm the root cause and determine the best path to resolution.