Identity Verification Issues

Incident Report for Spacetalk

Resolved

Identity Verification Issues is now resolved.
Posted Mar 03, 2026 - 11:51 AEDT

Update

Identity verification success rates have now improved following recent fixes.
Further UI improvements are planned to reduce chances of an error.
Please ensure, if using a Medicare card, that you use your middle initial as displayed on the card, in the middle name field on the screen.
Posted Jan 29, 2026 - 15:06 AEDT

Monitoring

We are aware of customers having issues failing ID checks when activating mobile services. If check did not pass, do not submit another request.
Wait 1 hr before trying again.
If using Medicare Card, enter middle initials as displayed on card.
Posted Jan 02, 2026 - 19:03 AEDT
This incident affected: Spacetalk Mobile Services (Australia) (Identity Verification).